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What is Excel? 
Microsoft Excel is spreadsheet software that provides an interface for storing, 

organizing, analyzing and working with any type of information like text, 

numbers, and date. It can be used in business to deal with expenses, 

revenues, budgets, and charts. 

The Excel file is often referred to as a workbook and each page in the 

workbook is a worksheet. Worksheet is a table which is a collection of 

cells organized into rows and columns.  

 

Cells are really where you enter any information; you can enter text, a date, 

number, or formula.   
 

Excel is a useful tool for business, scientific and statistical analysis. It can be 

used to: 

 Manage and organize data. 

 Analyze data. 

 Sort Data. 

 Apply Filters to data. 

 Create visual representation of data using Charts. 

Starting Microsoft Excel 2016 

By default, a new workbook has the name Book1 with one worksheet named 

Sheet1. In Sheet1 the active cell is A1.  

 

Excel file Extension is .xlsx     

 

 

 

 

 

 

http://spreadsheets.about.com/od/uvw/g/worksheet_def.htm
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Excel interface 

When you open Excel 2016 the window below will appear.  

 
 

Select Blank workbook to create a new workbook. 
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Title Bar: Title bar shows the workbook name which is by default Book1 

before saving. 

 
 

Quick Access Toolbar: It is part of Title bar it provides the most frequently 

used commands. You can customize the Quick Access Toolbar using drop-

down arrow to the right. 

 
 

Tabs: They appear across the top of the Ribbon and contain groups of related 

commands. Home, Insert, Page Layout are example of ribbon tabs. 

 

The File tab used to do file-related operations, like open, save, create new 

workbook, or close. 

 

Ribbons: contains commands organized in Groups for each tab 

 

Name Box: contains the address of the active cell or the name of range. 

Formula Bar: contains the content of the active cell. 

Active Cell: The cell where you enter any information surrounded by a 

rectangular box. 

 

Column bar: Columns are numbered as A, B, C etc. After Z, it will start series 

of AA, AB and so on.  

Row Bar: Rows are numbered as 1, 2, 3 etc.  
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Worksheets: Table 

which is a collection of 

cells organized into 

rows and columns. The 

active worksheet is 

bolded.  

 

 

 

 

Zoom Controls: You can slide left or right to zoom in or out. 

 

 

Backstage view 

Backstage view will appear when you click on 

the File tab on the Ribbon.   

 

  

http://spreadsheets.about.com/od/c/g/cell_ref_def.htm
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The numbers in the screenshot  

1- Click on the arrow to close Backstage view and return to Excel. 

2- Info: contains information about the current workbook. 

3- New: creates a new blank workbook. 

4- Open: opens recent workbooks, as well as workbooks saved to 

your OneDrive or on your computer.  

5- Save: saves the changes on the file that has already been saved. 

6- Save As:  Select the location, enter a file name for the workbook, and 

click Save. Use Save As to create a copy from original workbook using 

another name, different file type, and different location. 

7- Close: close the current workbook. 

 

Note that if you try to close a workbook 
and you haven’t saved your latest changes, 

Excel displays an alert message.  
­ Click on Save to save your 

changes before closing. 
­ Click on Don’t Save to close the workbook and discard these 

changes. 
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Cell references (addresses) 

Each cell has a cell address or reference, based on 

the column and row where it is located, for example cell B2 located in 

the column B and row 2.  
 

 Examples: 

o A123, S10,  AB1, AA100, BC78 

 

Remember: Active cell reference 

appears in the Name Box. 

Cell range 

Cell range is a group of selected cells. Referring to a cell range, use the 

reference of the first and the last cells in the range, separated by a colon (:). 

Example 1: 
Cell range A1:A5 include the cells A1, A2, A3, A4, and A5.  

Cell range A1:C3 include the cells A1, B1, C1, A2, B2, C2, A3, B3, and C3. 

Cell range B1:F1 include the cells B1, C1, D1, E1, and F1. 

Example 2: 
How many cells in the range B1:F1? 

Answer: 5 cells. 
How many cells in the range A1:C3? 

Answer: 9 cells. 

 

Data Types in Excel  

Excel allows you to enter different types of data into the cells, such as dates, 

text, formulas, time and numbers. 

1- Text:  is a combination of alphabetic letters, 

numbers, and symbols. 
Examples: 

First Mark  name1         12+9     name?? 

12,3          30/2/2020     1  0  5    1*2 

 

 By default, Text appear on the left of cell. 

 Typing any spaces within a number, it will be regarded as text. 
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2- Numbers  

 They can be integers or real, negative or positive. 
 By default, numbers appear on the right of cell. They can 

be formatted in different ways.  
 Dates and Times are stored as numbers in Excel.  

- The date 1/1/1900 is represented by a serial 
number 1. 

 
3- Formulas 

o Formula must start with an “= “sign. 
o It consists of relational or arithmetic operations (or 

special function) combined with numbers and/or cell 
references. 

Using Undo & Redo command  

To reverse the last changes, you make in a worksheet: 

1. Click the Undo icon  on the Quick Access toolbar or press Ctrl+Z 
from keyboard.  

2. To undo more than one action, click on the arrow next to undo 
icon to select the actions that you want to undo. 

 

Note: You can use Undo and Redo  (or Ctrl+Y) to switch back 

and forth between the actions in the worksheet. 

 

Dealing with Excel cells  

Cell is where you really enter your data, the active cell reference appears in 

the Name box. Note that when the cell is selected the cell's column and row 

headings are highlighted. 

 

 

 

 

 

Active cell 

reference 

appears in the 

Name box. 
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Select a cell 

1. One Cell: Click a cell to select. A border   will appear 

around the selected cell 
2. Cell range: Drag the mouse until all 

of the cells you want to select 
are highlighted. The address of 

the first cell in the range appear 
in name box.  

Cell content: 

1. Insert content: Type content into the selected cell, then 

press Enter from keyboard. The content will appear in 
the cell and the formula bar.  

2. Edit content: You can edit cell 
content by double click on the 

cell or from the formula bar. 
3. Delete content: Press 

the Delete or Backspace key 

from keyboard.  

Note: to delete content 

from multiple cells at once use Delete key while Backspace key will only 

delete the first cell content. 

Copy & Paste cell content: duplicates cell content 

1. Select the cell(s) you want to copy. 

2. On the Home tab, click the Copy command on the Clipboard 

group, or press Ctrl+C from keyboard. Note that the copied 
cells will surrounded by dashed box. 

3. Select the cell(s) where you want to paste. On 
the Home tab, click the Paste command on the 

Clipboard group, or press Ctrl+V from keyboard. 

4. The content will be pasted into the selected cells. 
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Cut & Paste cell content: moving cell content 

1. Select the cell(s) you want to cut. 

2. On the Home tab, click the Cut command on the 

Clipboard group, or press Ctrl+X from keyboard. The 
cut cells will have a dashed box. 

3. Select the cells where you want to paste the content.  

4. Click the Paste command on the Home tab, or press Ctrl+V on 

your keyboard. 

5. The cut content will be moved from the original cells 

and pasted into the selected cells. 

Format Cell content   

o Select the cells that you want to format.  

o Click the Format command in the Cells group on the Home tab.  

o Select “Format Cells” from the menu. Or Right-click on the selected 

cells, from the menu select “Format Cells”.  

o The Format Cells Dialog Box will appear. Choose the suitable tab to 

format the cell content.  
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1- Number tab:   

 

1236.25  

Will be  

1,236.250  

 

1.05  

Will be   

$1.050 

   

0.05  

Will be  

5.0%  



11 | P a g e                                               M a i s a  A l - K h a z a l e h  
 

 

1.5 

Will be  

1 1/2 

 

  

300  

Will be  

3.00E+ 02  
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Number formats Summary 

Format Description 

General Numbers are displayed just the way you type them.  

Number You can: 

1. Determine the number of decimal places 

2. Use thousands separator. 

3. Determine how to display negative numbers. 

Currency Used for monetary values. You can: 

1. Determine the number of decimal places. 

2. Choose the currency symbols.  

3. Determine how to display negative numbers. 

Date Displays date according to the type, location and Calendar that you specify.  

Time Displays time according to the type and location that you specify. 

Percentage Displays the percent (%) symbol and multiplies the cell value by 100. 

You can determine the number of decimal places. 

Fraction Displays a number as a fraction. You can determine the type of fraction that you want. 

Scientific Displays a number in exponential notation. You can determine the number of decimal 

places. 

Note: if you want to know the serial number for any date you can change the cell 

format to number, and vice versa. 
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Number group icons on Home Tab:  

1- Choose number format from the list (General, Number, Currency, 

Short Date, Long Date   etc.). 

2- Percent Style formats.  

3- Thousands Comma Style. 

4- Increase Decimal places. 

5- Decrease Decimal places. 

 

2- Alignment tab:      

1. Horizontal alignment: 
[Left, Center, Right]  

2. Vertical alignment: [Top, 
Center, Bottom ]  

3. Text control:  

o Shrink to fit: will 

automatically reduce the 

font size in a cell so that 

the cell content fits 

without wrapping.  

o Wrap text: cell content 

will appear on multiple 

lines without changing 

the column width.  

o Merge Cells: Merge two 

or more adjacent cells, 

the merged cells become 

one cell across multiple rows and columns.  

4. Orientation: rotate the text diagonally or vertically. It is a useful wat to 

label narrow columns. You can rotate the text up, down, clockwise, or 

counterclockwise, or align text vertically.  

5. Specify Text direction: 

o Left – to - Right. 

o Right – to – Left. 

o  

 

5 



14 | P a g e                                               M a i s a  A l - K h a z a l e h  
 

Alignment group icons on Home Tab:  

 

 

 

 

1. Orientation 

2. Text direction 

3. Indentation 

4. Wrap Text 

5. Merge and Unmerge Cells 

3- Font tab  

1- Font Type  

2- Font Style [Italic, Bold, Bold 

Italic] 

3- Font Size  

4- Underline:  

[None, Single, Double]  

5- Font color  

6- Font Effects:  

- Strikethrough: draw a line 

through the selected text or 

numbers.  

- Superscript: cell contents 

positioned slightly higher.  

- Subscript: cell contents positioned slightly 
lower.  

 Use subscripts and superscripts for 

individual characters in a cell.   
  

Font group icons on Home Tab:  

 

 

 

 

 

2 1 
Vertical Alignment 

Horizontal Alignment 

3 

4 

5 
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4- Border tab  

Excel offers different types of borders that you can add to individual cells or 

ranges of cells in your spreadsheet.  

To add borders to selected cell(s): 

1. Select the cell or range of cells 

that you want bordered. 
2. Select a line type from the Style 

area. 
3. Select a line color from the Color 

area. 
4. In the Border section of the format 

cells dialog box, select where you 
want the border applied.  

 None: to remove 
borderlines. 

 Outline: borderlines will 
surround the entire cell or 

cell range. 
 Inside: borderlines will 

appear around all cell edges 

for each selected cell. 
 

Border icon on Font group on Home Tab:  
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5- Fill tab: 

Adding a background color or a pattern using fill effects  

 

Fill color icon on Font group on Home Tab: 
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Format Cells as Table [i.e. using the predefined table’s styles]  

o Select the Cells.  

o Click the Format as 

Table command in the 

Styles group on the 

Home tab, and choose 

the appropriate style.  

o Select this check box 

[My table has headers] if 

your table has column 

headings.  

   

 

 

 

 

 

 

 

The table will have drop-down 

arrows in their headers; you can remove these arrows by:  

 Click the Convert to Range command in the Tools group on the 
Design contextual tab.  

   

Note: the contextual tab Design appears only when you choose one of the 

styles.    
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Cell Styles 

Cell style is a pre-defined set 

of formats, such as fonts, font 

sizes, number formats, 
borders, and shading.  

1. Select the cell, then from 

Home tab, Styles 
group, and click on Cell 

Styles. 
2. Choose the suitable 

style. 

 

 

 

Copy Formats with Format Painter 

1. Select the cell(s) that you want to copy their formats. 
2. On the Home tab, click on the Format Painter icon 

on the clipboard group.  
3. Select the cells where you want to apply the copied 

formats. 

Using Clear command   

1. Click the Clear button   , in the Editing group On the Home tab.  

2. Choose one of the following:  

 Clear All: will clear all contents, formats, and comments in the selected 

cells.  

 Clear Formats: will clear only the formats in the selected cells.  

 Clear Contents: will clear only the contents and leaving the comments 

and any applied formats in the selected cells.  

 Clear Comments: will clear any comments in the selected cells if there 

is any.  

 

Notes:  If you select a cell or a group of cells and then press DELETE from 

the keyboard, this will clear the cell contents only and leaving the cell formats. 



19 | P a g e                                               M a i s a  A l - K h a z a l e h  
 

Dealing with Excel Columns & Rows: 

Select column or row: 

o To select a single column or row, click on the column heading [A, B,…] 

or row heading number [ 1, 2, ….] . 

o To select adjacent (متتالية) columns or rows, click on the first column or 

row heading and drag to the last one. Or press shift key hold down 

while you select the last one. 

o To select multiple columns or rows, click on the first column or row 

heading and then hold down CTRL while you select other headings.  
Modify column width: 

Position the mouse cursor over the column line in the 

column heading, and then drag the cursor to 

the right to increase the column width or to the left to 

decrease the column width. 

OR  Click the Format command in the Cells group on the Home tab. 

Select  

1. Column Width… to enter a specific column width. 

2. Select AutoFit Column Width to adjust the column width 

according to the contents of that column so all of the 

content will fit. 

NOTE: If you see ####### in a cell, it means that the column width is 

not wide enough to display the cell content. You have to increase the 

column width to display the cell content. 

Modify row height: 

 Position the mouse cursor over the row line in the row 

heading, and then drag the cursor down to increase the 

row height or up to decrease the row height.OR 

 Click the Format command in the Cells group on 

the Home tab. Select : 

1. Row Height… to enter a specific row height. 

2. AutoFit Row Height to adjust the row height 

according to the contents of that row so all of the 

content will fit. 
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Insert columns or Rows: 

1- Insert Columns: 

Select the column to the right of where you want the new 

column to appear. The new column always appears to the left 

of the selected column (i.e. before the selected column). On 

the Home tab, click the Insert command in the Cells group 

 Insert Sheet Columns.  

2- Insert rows: 

 Select the row to the bottom of where you want the new row to appear. 

The new row always appears above the selected row. On the Home 

tab, click the Insert command in the Cells group  Insert Sheet Rows.  

Or: Right click on the column or Row where you want the 

new one to appear. Choose Insert form the list. 

Delete columns or Rows: 

 Select the column or row. On the Home tab, click 

the Delete command in the Cells group. 

Or:Right click on the column, choose Delete form the list. 

Hide rows or columns: 

1. Select the rows or column headings that you 

want to hide. 
2. Right-click the selected, and then select Hide 

or Click the Format button in the Cells group 
on the Home tab and click on Hide & Unhide. 

3. Click on Hide Rows or Hide Columns. 
NOTE:  

- The rows heading numbers order are 
indicator that you've hidden rows.  

- The columns heading alphabetical order 

are indicator that you've hidden 
columns.  

 

Unhide (show) rows or columns: 

1. Select the adjacent rows for the hidden rows.Right-click the selected 

rows, and then select Unhide  

Or Click the Format button in the Cells group on the Home tab and click on 

Hide & Unhide. Click on Unhide Rows or Unhide Columns. 
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Dealing with Excel Worksheets 
By default, a new workbook has one worksheet, you can select, rename, insert 
new worksheets, delete, hide, unhide [show], copy and move worksheets. 

Navigating within a worksheet 

 Using the mouse. 
 Use the arrows keys from keyboard. 

 Enter key will move to the cell that is below the active cell. 
 Tab Key will move to the cell that is on the right of the active cell. 

 

Selecting the entire worksheet 

You can select the entire worksheet by clicking the square to the 

immediate left of the Column A and above the Row 1. 

Renaming worksheets 
1. On the Home tab, click the Format command in the Cells 

group. 
2. Select Rename Sheet. Type a new name. 

OR 

1. Right-click on the sheet tab. Click on Rename from the 
menu. Type the new name.  

 

Insert a new worksheet: 

1. Select the sheet to the right of where you want the new sheet to appear. 
2. On the Home tab, click the Insert command in the Cells group. 

3. Select Insert Sheet. The new sheet always appears to the left (i.e. 

before) of the selected sheet. 
OR: Right-click on the sheet tab (the sheet to the right of where 

you want the new sheet to appear), Click on the Insert from 

the list.  

OR: Click on the icon shown below, the new worksheet will be 

named Sheet4, Sheet5, ….. 

 

Delete Worksheet: 

1. Select the sheet you want to delete. 

2. On the Home tab, click the Delete command in the Cells group. From 
the menu, select Delete Sheet. 

OR: Right-click on the sheet tab that you want to delete, and Click on 

the Delete from the list. 
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Copy Excel Sheet 

Method 1: Use drag and drop to Copy Excel sheet  

- Click on the tab for the sheet that you 
want to copy, hold down the Ctrl key 

and drag the tab to the place you want. 

Method 2: Copy the sheet within the same workbook 

1. On the Home tab, click the Format command in the Cells group and 
select move or copy sheets OR Right-click on the sheet tab and then click 

Move or Copy 
from the menu.  

2. Excel will open the 
Move or Copy 

dialog box.In the 
Before Sheet list 

box, select location 
you want to drop 

the copy. 
3. Check the Create 

a Copy check box. 
 

Method 3: Copy the sheet to a another 

workbook 

o In the To Book: select the (New Book) option 

to copy to a new workbook. 
o In the To Book: drop-down list, select the 

workbook to which you want to copy 
worksheet. [Note that the workbook that 

you want to copy on it should be opened] 

Move Excel Sheet 

Method 1: Use drag and drop to move Excel 

sheet  
Click on the sheet(s) that you want to move and drag them to a new 

location. 

 
Example: move Sheet1 and Sheet3 

to the end of the workbook. 
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Method 2: Move the sheet within the same 
workbook 

1. On the Home tab, click 

the Format command in the Cells 

group and select move or copy sheets 
OR Right-click on the sheet tab and then 

click Move or Copy from the menu. Excel 
will open the Move or Copy dialog box. 

2. In the Before Sheet list box, select 
location you want to drop the copy. 

3. The Create a Copy check box should be 
empty. 

Method 3: Move the sheet to a another 

workbook 

1. In the To Book: select the (New Book) 

option to move the sheet to a new workbook. 
2. In the To Book: drop-down list, select the 

workbook to which you want to move 
worksheet. 

Remember:  

- If you want to copy the sheets, select the 
Create a Copy check box. Otherwise let this 

option deselected to move rather than copy 
the sheet. 

- To move or copy a sheet from one Excel 
file to another, these workbooks should be 

previously opened. 

Hide or Unhide (show) worksheets 

To hide a worksheet 

1. Select the worksheet that you want to hide.On the Home tab, click the 

format command in the Cells group. 
2. Under Visibility, click Hide & Unhide, and then click Hide Sheet. 

OR Right-click on the sheet tab and then click Hide from the menu. 

To show a hidden worksheet 

1. On the Home tab, click the format command in the Cells group. 
2. Under Visibility, click Hide & Unhide, and then click Unhide Sheet. 

3. Unhide sheet dialog box will appear; double-click the name of the hidden 
sheet that you want to show. 

OR Right-click on the sheet tab and then click Unhide… from the menu. 

Remember: Hide a sheet, column, or row doesn’t mean delete. 
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Comments  
Comments allow you to add Notes or more 

descriptive information to that cell in a popup 

message. A red triangle appears in the upper 

right corner of the cell.  

Adding Comments:  

1. Select the cell. Click New Comment, in 

the Comments group on Review tab. Type the 

comment.  

 

Note: Red triangle appears in the upper right- corner of 

the cell. The comment text appears when you place your mouse over the cell. 

Editing Comments  

Editing a comment allows you to change or add to the information you have 

placed within a cell as a comment. 

1. Select the cell that contains the comment. Click Edit Comment in the 

Comments group on Review tab. 

2. The Comment box appears, make your changes then click another cell. 

Deleting Comments  

1. Select the cell which contains the 

comment to be deleted. 
2. Click Delete Comment in the 

Comments group, on Review tab.  

Note: you can delete a comment by Clear 

command in the Editing group, on Home tab. From the list choose Clear 

Comments.   

Show All Comments  

By default, the comments appear only when 

you hover over the cell that contains the 

comment to show all the comments at once.  

- Click Show All Comments, in the 

Comments group On the Review tab.  

 

Navigate between Comments 

Click Previous & Next, in the Comments 

group On the Review tab to navigate through 

the comments. 
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Using AutoFill  

 Copy the same data to other adjacent cells in the row or column. 

 Continue a pattern (series) for data like numbers, dates, and the days 
of a week or months.   

Using auto fill to copy data  

1. Select the cell that you want to copy its contents and hover over the 

bottom right corner of the selected cell until the mouse pointer 

changes to a black cross   .  

2. Drag the fill handle [small black square] over the cells that you want 

to fill - either down a column or across a row.  

Using auto fill to fill weekdays or months  

1. Enter the starting day into a cell (Sunday, Monday, Tuesday, or 

whatever…) or the starting month (April, May, whatever…)  

2. Hover the mouse pointer over the lower-right corner of the cell until the 

mouse pointer changes to a black cross  .  

3. Drag the fill handle [small black square] over the cells you want to fill - 

either down a column or across a row. 

 

Example 1:  

AutoFill: Series - Months AutoFill: Series – Weekdays 
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Example 2:  

 If you want to copy the value 1, just drag the fill handle to adjacent column 

or row.  

 If you want to fill for a series like 1, 2, 3, 4, 5..., click Auto Fill Options  

  and choose the option Fill Series.  

 

Example 3:  

AutoFill: Fill Series AutoFill: Copy Cells 

 

 

 

 

 

 AutoFill: Copy Cells   AutoFill: Fill Series  
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Sorting 

 In Excel you can sort numbers, text or dates, in either ascending (تصاعدي) or 

descending (تنازلي) order. If there is blank cells, they are always placed last 

in a sort.  

You can find sort command on:  

 Data tab, Sort& Filter group. 
 Home tab, Editing group.  

Sort Text Data  

1. Click any cell in the column that you want to sort by. On the Home tab, 

select Sort & Filter from Editing group. OR Data tab, Sort& Filter group.  

2. Choose either Ascending  (Sort A to Z) or Descending   (Sort Z to A) 

order.  

Sort Number Data  

1. Click any cell in the column that you want to sort by. On the Home tab, 

select Sort & Filter from Editing group. OR Data tab, Sort& Filter group.  

2. Choose either Ascending  (Sort Smallest to Largest) or Descending 

  (Sort Largest to Smallest) order.  

Sort Date Data  

1. Click any cell in the column that you want to sort by.On the Home tab, 

select Sort & Filter from Editing group. Or Data tab, Sort& Filter group.  

2. Choose either Ascending  (Sort Oldest to Newest) or Descending  

(Sort Newest to Oldest) order.  

 

Warning:When you Sort your data excel will automatically expands your 

selection from a single cell to include all adjacent data. It's dangerous to 

select one column to sort, each row of adjacent data stay the same (i.e. excel 

will sort only the selected data, the data next to your selection will not be 

sorted).  
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Example: If we select 

Column A to sort in ascending 

order, Excel show a Sort 

Warning message 

 

 

 

If we choose Expand the selection, the result will be:  

 

 

If we choose Continue with the current selection, the result will be: 

Note: This option will only sort column A, which means that our 

data is no longer correct.  

 

Custom Sort    

1- Sorting Months and Weekdays  

1. Select a cell or range in the list you want to sort.On the Home ribbon, 

select Sort & Filter, and choose Custom Sort.  

2. The Sort Window will open. Select the custom List under Order. The 

Custom List Dialog Box will Open  
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3. Select the List 

that you want 

or add your 

own list using 

NEW LIST, 

then click OK.  

  

 

 

 

2- Sorting columns from Left to Right  
Default Sorting is top to bottom, but 

there is another option to sort is from left 

to right. 

  

1. On the Home tab, select Sort & 

Filter, and choose Custom Sort. The 
Sort Window will open.  

 
2. Click on Options button, then in the 

Sort Options dialog box choose Sort 

left to right. 

 
 

3. Select the Row number to sort. Select order, then click OK.  

 
3- Recognizing a Header Row  

In Excel you can keep the first row on top (headers) in their 

places when you sort 

your data as follow: 

1. In Custom Sort 

dialog box, Check My 
data has headers. 
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Sort sequences  

In ascending order, Numbers and Dates are sorted first, then Text. 
Blank cells are sorted at the end both in ascending and descending sorts. 

Example: 

Data Ascending Order Descending Order 

   

 

Filtering   

You can filter data to display a subset of data and analyze information. 

Filtering is temporarily hiding data in a spreadsheet.  

You can find Filter command on:  

 Data tab, Sort& Filter group. 

 Home tab, Editing group.  
 Excel automatically adds Drop-down arrows besides each column 

heading.  Click the drop-down arrow next to the heading you would like 

to filter. 

 The Filter Type depends on the data type in that column.  

Text Filters:  

  

    

  

  

  

  

 

 

 

 



31 | P a g e                                               M a i s a  A l - K h a z a l e h  
 

Number Filters:  

 

 

Date Filters:  

Quarter1:  

January, February, March 

Quarter 2:  

April, May, June 

Quarter 3:  

July, August, September  

Quarter 4:  

       October, November, December 

 

Example: The data below filtered by 

First column. Note that the filter icon is beside 

the number column and the rows 6, 8, and 9 

are hidden.   

  

To clear one filter:  

1. Click on the drop-down arrows next to a filtered 

column.  

2. Choose Clear Filter From...  

 

Note: To remove all filters, click on the icon   in the Sort & Filter group.  
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Using Filter with multiple criteria [Logical operators And,Or] 

 Using And 
 

 

 

 

 

   

 Using Or 

 

 

 

 

 

 

 

 

Exercise 
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1. The Data is sorted according to ---------- column in ------------- order. 

2. There is 1 filter on -------- column that displays the bills No. greater 

than or equal to 1000. 

3. The suitable filter to show all the bills in 11/5/2020 is ------------------. 

4. The suitable filter to show all the bills except the bill 3001 is-------. 

5. The suitable filter to show all the bills in April, May, and June is -------. 

6. The suitable filter to show top 5 bills value is-----------------------. 

7. The suitable filter to show the bill’s number in the range [1000,2000]--- 

 

Naming a Cell or Range of cells    
You can assign a name to a cell or a range of cells that allow you to use this 

name in formulas or functions in your worksheets.  

Naming cells  
1. Select the cell or cell range that you want to 

name.  

2. Click Define 

Name in the 

Defined Names 

group on the 

Formulas tab.  

 
3. The New Name dialog box appears.  

 

 In the Name text box, type the name, in this example we type 

Values .Now when you select the cells from A2:A5 the name 

Values will appear in the name Box.  

 

 

Remember:  

 Range Name is up to a 255-characters.   

 Range names are not case-sensitive.  

 The first character of range name must be a letter, or an underscore.  

 No spaces in a range name and no special symbols.  

 You cannot use a cell address as a name. For example, A2 or AB123.  
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Managing Range Names  
The Name Manager provides a list of all names in the 

current workbook which you can create new range 

names, edit, or delete.  

Click Name Manager in the Defined Names group 

on the Formulas tab. The Name Manager Widow will 

open: 

 

 Use New button to create new names.  

 Use Delete button to delete the selected name.  

 Use Edit button to edit the name or range of cells for the selected 

name.  

Naming Cells using row or columns labels:[Create from Selection]  

1. Select the cell range that you want to name, in this example A1:D1. Click 

the Create from Selection command in the Defined Names group on 

the Formulas tab. 

 

  
 Choose the location that contains the labels (names) by selecting the Top 

row, Left column, Bottom row, or Right column check box.  

In this example if we Check the: 

Left column the name will be values for cells B1:D1. 

Right column the name will be result for cells A1:C1. 
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Paste Special  
By default, Excel copies all the information 

(content, formats, comments...) when you 

paste the data in the selected cells.  

1. Select the cell(s) that you want to copy or 
cut.  

2. Select the cell(s) where the results should 
be pasted.  

3. Select Paste Special from the clipboard 

group on the home tab.  

4. The Paste Special dialog box appears. 

Select one of the following options:  

 All: pastes all content (formats, 
information, and formulas) in 

the copied cell; it is the default option  
 Formulas: pastes only the formula but remember that any relative 

cell references within the formula will be changed according to the 
new location.  

 Values: pastes only the contents, if you copy a formula and use this 
option this will copy only the result (values) of the formula from the 

selected cell.  
 Formats: pastes the formatting applied to the cell without content.  

 Comments: pastes only the comments from the copied cell (s) 
without contents or any formats.  

Operation:  

Used to perform some calculations based on the values in the copied or cut cells 

and the values in the destination cells:  

 Add: Add the values that were copied or cut to the values in the 

destination cells [where you want to paste]. 

 Subtract: Subtract the values that were copied or cut to the values 

in the destination cells [where you want to paste].  

 Multiply: Multiply the values that were copied or cut to the values 

in the destination cells.  

 Divide: Divide the values that were copied or cut to the 

values in the destination cells.  
Transpose  

It used to change the orientation of the pasted cells. By default, the pasted cells run 

down across the rows of a single column, the transpose option change the orientation 

to be across the columns of a single row.  

http://www.uwec.edu/help/Excel07/ws-pastesp.htm#options
http://www.uwec.edu/help/Excel07/ws-pastesp.htm#options
http://www.uwec.edu/help/Excel07/ws-pastesp.htm#options
http://www.uwec.edu/help/Excel07/bas-cellref.htm
http://www.uwec.edu/help/Excel07/bas-cellref.htm
http://www.uwec.edu/help/Excel07/bas-cellref.htm
http://www.uwec.edu/help/Excel07/bas-cellref.htm
http://www.uwec.edu/help/Excel07/bas-cellref.htm
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Working with Formulas  
Operators in Excel 

1. Arithmetic [Mathematical] operations: 

o Addition        +  

o Subtraction         -  
o Division         /  

o Multiplication * 
o Exponent        ^ 

Priority:  

1. Parenthesis 

2. Exponent 
3. Division and Multiplication from left to right. 

4. Addition and Subtraction from left to right. 

2. Relational [Comparison] Operators: 
o Greater than    > 

o Greater than or equal >= 
o Less than   < 

o Less than or equal  <= 
o Equal    = 

o Not equal   < > 

Priority: All have the same priority from left to right.  

Remember  The result of relational operators is either TRUE or FALSE  

Example: 

=10-4/2+3*2^2   

 Answer = 20 

 

=(10-4)/2+3*2^2

 Answer = 15 

 

= 50 = 100 

Answer = FALSE 

 

Remember: Avoid using numbers instead of cell reference with that number 

into a formula. Wherever possible, refer to the cell reference with that number 

in it. 
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Using defined Cell Names in Formulas  
Example: 

1. Select the cell B2 that you want to 

name. 
2. Click Define Name in the Defined 

Names group on the Formulas tab. 
The New Name dialog box appears. In 

the Name text box, type the name 
Bonus. 

3. In the cell C4 Write the formula =C4 + 

then go to the Formulas tab; Click on 
Use in Formula in the Defined 

Names group, then choose the name, and then Press Enter. 

Note: if the name is Not defined this will result in #Name? Error in the 

formula.  

Copy and Paste formulas  

There are two types of cell references used in formulas:   

 Relative references: changed when a formula is copied or cut to another 

cell. By default, all cell references are relative reference.  

 Absolute references: remain fixed, when a formula is copied or cut to 

another cell. It contains a dollar sign $ before the row or column header, 

or both.  

Using Relative Reference  

1. Type the formula = C2*D2*E2 to calculate the total mark value. Press 

Enter to display the result.  

  

2. Copy this formula to the cells F3,F4,…..F11.Note that the  formula will 

be copied to the selected cells with relative references, 
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3. The relative references for each cell, depending on their rows.  

  

Using absolute cell Reference  
Problem: suppose that you write the formula =F2+C13 in G2 When you 

copy the formula down in the column, Excel changes each cell reference to 

match the new row. We need to keep C13 fixed in the pasted cells so we 

have to change the cell reference from relative reference C13 to 

absolute reference as $C$13.   

In the Example below we want the value of bonus to be added for total:  

1. Type the 

formula  

=F2+$C$13  

  2. Now copy this 
formula to the other 
cells. Note that F2 
changed to F3 
[relative] while C13 
remain fixed.  
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Note: To make a cell reference absolute, Press F4 from keyboard.   

 

Formula Errors  

#####: occurs when the column is not wide enough to display its content. 

Solution: Increase the column width.  

                

#DIV/0! Error: occurs when a formula divide a number by 0 or by empty 

cell. In the example below the value of A2 is 0 in the given formula.  

Solution: You have to change the value of cell A2 to any non-zero 

value.  

         

#VALUE! Error:  occurs when a formula contains wrong type of argument.  

In the example below the value of A2 is TEXT in the given formula.  

 Solution:  You  have  to  change  the  value  of  cell  A2  to  a 

 number.  
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#NAME? Error: occurs when Excel does not recognize the name used in a 

formula. In the example below the value1 in the given formula is not defined 
in Excel.  

Solution: You have to define this name [Formulas Tab  Defined Names 

group Define Name command]  

      

#REF! Error: occurs when a formula refers to a cell reference that is NOT 

valid.  

Solution: Use a valid cell reference by deleting #REF! Argument in the 

formula. In the example below the given formula references A1 and A2. If we 

delete row 2 the reference of A2 is not valid anymore.  

              

Notes about Excel formulas: 

 The empty (blank) cell is considered 0 when used within a formula. 

 In Excel logical values (FALSE, TRUE), if they used in a formula the value 

of TRUE is 1 and the value of FALSE is 0. 

 It is not possible to use texts in mathematical formula. #VALUE! Error. 

 It is not possible to use text and logical values inside the quotation 

marks “ “ in the formula, it is considered as #VALUE! Error. 

 In formulas, numbers and date between quotation marks““ is correct. 

 Make sure that date is written in a correct format – otherwise it is 

considered as #VALUE! Error. 

 Writing any wrong name into the formula is considered as #NAME? 

Error, unless the name is a defined.  

 If we copy a formula with a defined name, it will be pasted as it in the 

destination cell. 

 

      
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Examples:  

Example 1:  

  

IF we copy the following formula:   D4=A2+B3 21 to the cells given below 

the result will be as follow:  

D3   =A1+B212  

D5    =A3+B437  

E4     =B2+C3 3  

E6    =B4+C57  

C4    =#REF!+A3 #REF!  

Example 2:  

If we copy the following formula:  D4 =A2+$B$3 21 to the cells given below 

the result will be as 

follow:  

  

D3   =A1+$B$311  

D5   =A3+$B$331  

E4   =B2+$B$3 3  

F6   =C4+$B$31  

C4  

=#REF!+$B$3#REF!  
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Example 3:  

If we copy the following formula:  D4 =A2+B$3 21 to the cells given 

below the result will be as follow:  

D3   =A1+B$311  

D5   =A3+B$331  

E4     =B2+C$3 3  

F5   =C3+D$31  

Example 4:  

If we copy the following formula:  D4 =A2+$B3 21 to the cells given below 

the result will be as follow:  

D3   =A1+$B212  

D5   =A3+$B437  

E4     =B2+$B3 3  

F5   =C3+$B48  

Example 5: 

1. The result of formula in C1  #DIV/0! 

2. The result of formula in C3  30 

3. The result of formula in C4  32 

4. The result of copying the formula in C4 and paste it in C5 is:  

 =VAL+B3 33 

5. The result of C3 and C4 after deleting the row 2 is: #REF! 

6. The result of C3 and C4 after selecting row 2 and pressing the delete 

key is (i.e. Delete the content NOT Row):  C30  C430   
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Example 6: 

Note that NUMBER is a defined name for the cell A9 
 

The Results of these formulas: 

 

 
 

 
 

 


